31 thoughts on “Will seafoam fix my boggy snowmobile? Bog series #7 Polaris indy lite.

  • May 30, 2019 at 11:05 am
    Permalink

    What is the temp out side while it's running indirect jetting for hot temp will cause big bog

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Lol, you need to burn the entire tank before you see any benefits and sea foam is not as magical as people think.

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Check the ramps on the primary clutch

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    1oz per gallon is what is recommended

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    One side has a fouled plug…

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    How about the clutching? primary spring? Seems to have an early engagement, also might be a bit weak on the secondary. Had similar issues with my 340 lite touring. Also had issues with having just too rich mixture, runs better when it's colder outside.

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Oh Yea Larry…Just Send It!

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Sorry to see, this wasn't finished. 87 Phazer: replaced Fuel pump, Impulse line and clamps to pump, Ignition coil, after doing EVERYTHING he had done. Fixed. Really think my problem was the Impulse line, and….Ignition coil.

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Love you vids. They help me out

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    My 96 Vmax 600 was set up sloppy rich by the factory. Bogged, horrible mileage, smoked out the whole county. Jetted down and installed hotter plugs and it ran like a champ.

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    I agree with other posters to check the exhaust flow. That's the last piece of the puzzle you haven't looked at yet (yes I watched all 7 videos!). It's a shame you've done all the difficult stuff but not been successful in getting rid of the bog. You should demonetize this series until you get it running right!

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    is the lighting and ignition coil original? my 2 cents is to confirm ignition timing.i assume 340,440 and 488 all have same components .I made my own timing wheel and pointer when i rebuild my 488(polaris timing casting marks were bang on but i wanted to make sure)

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    When a guy is expecting a happy ending,you can't take him there then leave him on the edge. Am i right……

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    So, you make a 7 video series on a bogging 340, don't find the problem and end the series?……… wtf…i thought i might learn something new. not cool imo.

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Sea foam and. Marvel mystery oil is majic- used it on COUNTLESS. Cars bikes atvs-and sleds for. 35 years. Always. Put extra

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Kinda disappointed I sat through the series just to be let down at the end..

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    The whole can. Run till empty.then see.

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    My sled ran fine before seafoam..now it runs like shit.

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Did you ever fix the bog? Wish you would have shown bleeding the oil line. Did you install an oil line filter?

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    was the secondary rebuilt?

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Love your channel, thanks for taking the time to put all this good info out there on all your videos, anxious to see how the old girl comes to life with the lower pilot jets!

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Off the top of your head. What size jet do would you need for the altitude between 7000 ft and 11000 ft in elevation?

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    What the he'll couldnthe problem be. U went thru just about everyrging

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Just got a Polaris Sprint 340 with the same problem. It’s fine when you first fire it up but after she warms up she bogs. Once it gets going it’s fine. But from a stand still and you start off she bogs

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Did you guys just give up on it?

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Did you guys ever find out what was wrong with the sled?

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    I can't find the link to Bog Series #8 ! Have you filmed it yet ?

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    because you rebuilt the engine, carbs and fuel pump it can only be stater,coil,wires,plugs ect. OR clutchs but im thinking stater or coil breaking down after 3-4000 rpm

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Hey POWERMODZ, I have a 97 Formula Z with a BOG ISSUE…. Think you can help me????

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    Probably needs new compass bearings

    Reply
  • May 30, 2019 at 11:05 am
    Permalink

    so i am just wondering did you ever get the crank looked into . there is a special piece that is in the centre of the crank and divides the bottom end preventing air exchange from one side to the other . another thing i found is that some people remove a piece from inside the airbox to improve air flow without realizing the piece is needed for one the motor warms up or is used on a ward day . that being said i still think its either the carbs or the motor that is causing the bog . those polaris fan cooled are about as good as those fan cooled motors used in the ski doo model . i wish someone would explain why the liquid cooled are so much better than those particular fan cooled .

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *